Problème Ajax dans une page web ou dans un embedded html

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème Ajax dans une page web ou dans un embedded html

Message  lolo750paso le Mer 3 Déc - 16:01

Bonjour à tous,

cela fait un petit moment que je teste tout un tas de solutions, mais rien à faire.
Je récupère une valeur par Ajax que je veux afficher sur un client Xibo, rien n'y fait, le code javascript fonctionne sur la page web que je créé, mais pas sur le client Xibo, est-ce que le moteur d'IE ne limiterait pas les appels Ajax? Je n'ai aucune erreur dans les logs du client, tout se passe comme si la requête ajax ne se faisait pas.
Avez-vous déjà eu ce genre de problème?

Merci de votre aide

Laurent

lolo750paso

Messages : 2
Points : 783
Date d'inscription : 03/12/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Ajax dans une page web ou dans un embedded html

Message  saroumane le Ven 5 Déc - 13:14

Bonjour,

personnellement j'ai créé une page web PHP que j'appelle en tant que webpage et non en page emdbed. Je ne pas eu de problème particulier.
Les seuls problèmes que j'ai pu rencontré étaient liés à la désactivation du javascript dans les paramètres du navigateur. Je ne pense pas qu'il puisse y avoir de problème dans la récupération de tes données en XML ou en JSON par celui-ci.

Je suis xibo 1.4.2  avec IE8 comme navigateur.

Cdt,

saroumane
Techos
Techos

Messages : 59
Points : 1205
Date d'inscription : 05/12/2013
Age : 46
Localisation : Val de Marne

Feuille de personnage
Utilisateur Xibo: Oui
Plateforme Xibo: Windows
Nombre de player Xibo:
10/13  (10/13)

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Ajax dans une page web ou dans un embedded html

Message  lolo750paso le Ven 5 Déc - 13:33

Bonjour,

merci pour ta réponse, la page php fonctionne ici aussi, mais en fait j'affiche mon ensolleillement avec une jauge en javascript, et c'est beaucoup plus joli avec le rafraichissement de la donnée en ajax (pas de clignotement). Je suis arrivé à faire fonctionner l'embedded sur un client de test en modifiant l'émulation du navigateur (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION ajouter un DWORD XiboClient.exe à 11000 pour simuler IE11), mais sur mon client de prod, rien à faire, il doit y avoir aussi des modifs à faire sur les options internet...
Par contre, après cette modif, mes embedded sont sur un fond blanc, impossible à rendre transparent...
Je cherche encore,

Laurent

lolo750paso

Messages : 2
Points : 783
Date d'inscription : 03/12/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Ajax dans une page web ou dans un embedded html

Message  Contenu sponsorisé Aujourd'hui à 1:35


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum